Back to overview
Downtime

Power delivery issues in San Jose

Jun 27, 2026 at 10:44pm UTC
Affected services
North America / San Jose

Resolved
Jun 28, 2026 at 12:05am UTC

Power has been restored, it's possible to start CloudDecks again.

Created
Jun 27, 2026 at 10:44pm UTC

Our storage cluster in San Jose is experiencing power delivery issues. We're in contact with the datacenter engineers to resolve the problem.