Back to overview
Downtime
Power disruption in Frankfurt
May 5, 2026 at 10:15am UTC
Affected services
Europe / Frankfurt
Resolved
May 5, 2026 at 10:49am UTC
Power has been restored, all services are operational again.
Affected services
Created
May 5, 2026 at 10:15am UTC
A power disruption in Frankfurt is preventing CloudDecks from starting successfully. We're in contact with datacenter engineers to get the problem resolved.
Affected services