Back to overview
Resolved
Server maintenance
Sep 1, 2026 at 9:30am UTC
–
Sep 1, 2026 at 4:00pm UTC
Affected services
Europe / Amsterdam
Resolved
Sep 1, 2026 at 4:00pm UTC
Maintenance ended
Affected services
Created
Sep 1, 2026 at 9:30am UTC
We're performing server maintenance to address performance issues.
Affected services